Next Generation CMS :: Форум поддержки

Заинтересовала наша система? Тогда этот форум для Вас!

Вы не зашли.

#51 2020-06-27 16:22:54

vitaly
Администратор
Откуда Россия
Зарегистрирован: 2008-10-08
Сообщений: 2,790
Рейтинг :   115 

Re: NGCMG версии 0.9.6 [Release Candidate 1][GIT 20190524]

irbees2008 пишет:

Последняя правки

Не удалось применить патч! Пропуская. Ошибка была: Невозможно применить патчи патчей / composer / 1.diff


  [Исключение]
  Невозможно применить патч P-1: addGlobalRef (patches / composer / 1.diff)!

Это где, как и в каком виде?

Не в сети

#52 2020-06-27 18:18:50

irbees2008
Продвинутый чайник
Откуда Шахтинск
Зарегистрирован: 2012-03-14
Сообщений: 2,727
Рейтинг :   114 
Сайт

Re: NGCMG версии 0.9.6 [Release Candidate 1][GIT 20190524]

Опен сервер,в командной строке , при установке компосера, сначала запросил токен с гита, пришлось токен получить для системы, далее каждый пакет подтверждать токеном, и на последнем пакете вылезло это. и все в браузере

Warning: require(F:\OpenServer\domains\ngcms-core-utf/vendor/autoload.php): failed to open stream: No such file or directory in F:\OpenServer\domains\ngcms-core-utf\engine\core.php on line 21

Fatal error: require(): Failed opening required 'F:\OpenServer\domains\ngcms-core-utf/vendor/autoload.php' (include_path='.') in F:\OpenServer\domains\ngcms-core-utf\engine\core.php on line 21

Не в сети

#53 2020-06-28 08:27:52

rusiq
гуру
Зарегистрирован: 2014-07-16
Сообщений: 585
Рейтинг :   36 
Сайт

Re: NGCMG версии 0.9.6 [Release Candidate 1][GIT 20190524]

vitaly, есть возможность опубликовать систему на https://packagist.org/?

Не в сети

#54 2020-06-28 13:29:40

vitaly
Администратор
Откуда Россия
Зарегистрирован: 2008-10-08
Сообщений: 2,790
Рейтинг :   115 

Re: NGCMG версии 0.9.6 [Release Candidate 1][GIT 20190524]

irbees2008 пишет:

Опен сервер,в командной строке , при установке компосера, сначала запросил токен с гита, пришлось токен получить для системы, далее каждый пакет подтверждать токеном, и на последнем пакете вылезло это. и все в браузере

Warning: require(F:\OpenServer\domains\ngcms-core-utf/vendor/autoload.php): failed to open stream: No such file or directory in F:\OpenServer\domains\ngcms-core-utf\engine\core.php on line 21

Fatal error: require(): Failed opening required 'F:\OpenServer\domains\ngcms-core-utf/vendor/autoload.php' (include_path='.') in F:\OpenServer\domains\ngcms-core-utf\engine\core.php on line 21

Я добавил автоустановку composer'а только при установке в docker'е и тестировал это только под linux.
Если ставишь composer сам, то это вопрос к твоему openserver'у.

Если я не понял вопроса, то опиши порядок действий типа такого:
1. скачал исходники вот сюда
2. сделал вот это
3. не работает вот то (я не понимаю, куда у тебя мог удалиться core.php, если только проблемы с настройками openserver'а)

Не в сети

#55 2020-06-28 13:30:45

vitaly
Администратор
Откуда Россия
Зарегистрирован: 2008-10-08
Сообщений: 2,790
Рейтинг :   115 

Re: NGCMG версии 0.9.6 [Release Candidate 1][GIT 20190524]

rusiq пишет:

vitaly, есть возможность опубликовать систему на https://packagist.org/?

Могу, но тогда с тебя корректный (с точки зрения этого сайта) composer.json.

Не в сети

#56 2020-06-28 13:38:17

rusiq
гуру
Зарегистрирован: 2014-07-16
Сообщений: 585
Рейтинг :   36 
Сайт

Re: NGCMG версии 0.9.6 [Release Candidate 1][GIT 20190524]

vitaly, хорошо. Версию PHP какую ставить?) Список PHP-расширений добавлять в раздел require?

Не в сети

#57 2020-06-28 14:44:34

vitaly
Администратор
Откуда Россия
Зарегистрирован: 2008-10-08
Сообщений: 2,790
Рейтинг :   115 

Re: NGCMG версии 0.9.6 [Release Candidate 1][GIT 20190524]

rusiq пишет:

vitaly, хорошо. Версию PHP какую ставить?)

7.2.x (где x - на твоё усмотрение).

rusiq пишет:

Список PHP-расширений добавлять в раздел require?

Да, разве есть варианты?

Не в сети

#58 2020-06-30 21:53:26

vitaly
Администратор
Откуда Россия
Зарегистрирован: 2008-10-08
Сообщений: 2,790
Рейтинг :   115 

Re: NGCMG версии 0.9.6 [Release Candidate 1][GIT 20190524]

Готово:
https://packagist.org/packages/vponomarev/ngcms-core

Теперь осталось проверить корректность работы :)

Не в сети

#59 2020-06-30 22:25:04

rusiq
гуру
Зарегистрирован: 2014-07-16
Сообщений: 585
Рейтинг :   36 
Сайт

Re: NGCMG версии 0.9.6 [Release Candidate 1][GIT 20190524]

Устанавливается, если указать минимальную стабильную версию dev

composer create-project vponomarev/ngcms-core blog -s dev

Не в сети

#60 2020-06-30 23:59:47

vitaly
Администратор
Откуда Россия
Зарегистрирован: 2008-10-08
Сообщений: 2,790
Рейтинг :   115 

Re: NGCMG версии 0.9.6 [Release Candidate 1][GIT 20190524]

rusiq пишет:

Устанавливается, если указать минимальную стабильную версию dev

composer create-project vponomarev/ngcms-core blog -s dev

Супер!

Не в сети

#61 2020-07-01 14:27:17

irbees2008
Продвинутый чайник
Откуда Шахтинск
Зарегистрирован: 2012-03-14
Сообщений: 2,727
Рейтинг :   114 
Сайт

Re: NGCMG версии 0.9.6 [Release Candidate 1][GIT 20190524]

rusiq пишет:

Устанавливается, если указать минимальную стабильную версию dev

composer create-project vponomarev/ngcms-core blog -s dev

По подробнее можно для чайников

Не в сети

#62 Вчера 16:02:38

rusiq
гуру
Зарегистрирован: 2014-07-16
Сообщений: 585
Рейтинг :   36 
Сайт

Re: NGCMG версии 0.9.6 [Release Candidate 1][GIT 20190524]

irbees2008, скачиваете, устанавливаете Composer. Запускаете командную строку в рабочей директории (например, в xampp – это C:\xampp\htdocs). Используете команду composer create-project vponomarev/ngcms-core blog -s dev для скачивания исходников NGCMS с репозитория Github в директорию blog. Директория будет автоматически создана при выполнении команды. Дальше уже устанавливаете саму систему.

То есть не нужно скачивать архив с репы и распаковывать в ручную. При этом Composer проверит минимальные требования перед скачиванием.

Изменено rusiq (Вчера 16:16:50)

Не в сети

Подвал раздела

Работает на FluxBB